const regex = /\s(?i)case\s{0,1}:\s{0,1}(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(?i)case\\s{0,1}:\\s{0,1}(\\d+)', 'g')
const str = `This is a string. we want case:12345 and case:5656759 in the title 2.
case:
CASE : 122235 or CaSe:6666 or case: 12345 or cAsE :13343`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}