import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(?i)case\\s{0,1}:\\s{0,1}(\\d+)";
final String string = "This is a string. we want case:12345 and case:5656759 in the title 2.\n"
+ " case:\n"
+ "CASE : 122235 or CaSe:6666 or case: 12345 or cAsE :13343";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}