import re
regex = re.compile(r"\s(?i)case\s{0,1}:\s{0,1}(\d+)")
test_str = ("This is a string. we want case:12345 and case:5656759 in the title 2.\n"
" case:\n"
"CASE : 122235 or CaSe:6666 or case: 12345 or cAsE :13343")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")