package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s(?i)case\s{0,1}:\s{0,1}(\d+)`)
var str = `This is a string. we want case:12345 and case:5656759 in the title 2.
case:
CASE : 122235 or CaSe:6666 or case: 12345 or cAsE :13343`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}