using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?i)case\s{0,1}:\s{0,1}(\d+)";
string input = @"This is a string. we want case:12345 and case:5656759 in the title 2.
case:
CASE : 122235 or CaSe:6666 or case: 12345 or cAsE :13343";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}