re = /\s(?i)case\s{0,1}:\s{0,1}(\d+)/
str = 'This is a string. we want case:12345 and case:5656759 in the title 2.
case:
CASE : 122235 or CaSe:6666 or case: 12345 or cAsE :13343'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end