$re = '/\s(?i)case\s{0,1}:\s{0,1}(\d+)/';
$str = 'This is a string. we want case:12345 and case:5656759 in the title 2.
case:
CASE : 122235 or CaSe:6666 or case: 12345 or cAsE :13343';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);