# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^#([A-Z]):\s/$1:] /gm;t' <<< "Ludus øfficiis suåvitate sea in, ius utinam vivendum no, mei nostrud necessitatibus te?
#A: This is some info.
#B: Some more info.
#C: More stuff.
#A: The end.
Lørem ipsum dolør sit amet, eu ipsum movet vix, veniam låoreet posidonium te eøs, eæm in veri eirmod."