package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#([A-Z]):\s`)
var str = `Ludus øfficiis suåvitate sea in, ius utinam vivendum no, mei nostrud necessitatibus te?
#A: This is some info.
#B: Some more info.
#C: More stuff.
#A: The end.
Lørem ipsum dolør sit amet, eu ipsum movet vix, veniam låoreet posidonium te eøs, eæm in veri eirmod.`
var substitution = "$1:] "
fmt.Println(re.ReplaceAllString(str, substitution))
}