$re = '/^#([A-Z]):\s/m';
$str = 'Ludus øfficiis suåvitate sea in, ius utinam vivendum no, mei nostrud necessitatibus te?
#A: This is some info.
#B: Some more info.
#C: More stuff.
#A: The end.
Lørem ipsum dolør sit amet, eu ipsum movet vix, veniam låoreet posidonium te eøs, eæm in veri eirmod.';
$subst = "$1:] ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;