import Foundation
let pattern = ##"^#([A-Z]):\s"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Ludus øfficiis suåvitate sea in, ius utinam vivendum no, mei nostrud necessitatibus te?
#A: This is some info.
#B: Some more info.
#C: More stuff.
#A: The end.
Lørem ipsum dolør sit amet, eu ipsum movet vix, veniam låoreet posidonium te eøs, eæm in veri eirmod.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1:] "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)