import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#([A-Z]):\\s";
final String string = "Ludus øfficiis suåvitate sea in, ius utinam vivendum no, mei nostrud necessitatibus te? \n\n"
+ "#A: This is some info.\n"
+ "#B: Some more info.\n"
+ "#C: More stuff.\n"
+ "#A: The end.\n\n"
+ "Lørem ipsum dolør sit amet, eu ipsum movet vix, veniam låoreet posidonium te eøs, eæm in veri eirmod.";
final String subst = "$1:] ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}