# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\[[^\]]*\]\s+|\s+\[[^\]]*\]//gm;t' <<< "There is a [blue] cloud on top of that [big] elephant"