using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[[^\]]*\]\s+|\s+\[[^\]]*\]";
string substitution = @"";
string input = @"There is a [blue] cloud on top of that [big] elephant";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}