$re = '/^\[[^\]]*\]\s+|\s+\[[^\]]*\]/m';
$str = 'There is a [blue] cloud on top of that [big] elephant';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;