package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[[^\]]*\]\s+|\s+\[[^\]]*\]`)
var str = `There is a [blue] cloud on top of that [big] elephant`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}