#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\[[^\]]*\]\s+|\s+\[[^\]]*\]"
Local $sString = "There is a [blue] cloud on top of that [big] elephant"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)