re = /^\[[^\]]*\]\s+|\s+\[[^\]]*\]/m
str = 'There is a [blue] cloud on top of that [big] elephant'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result