import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\|description =\\s*)([^\\n]+)(.*\\[\\[)([^\\|]+\\|)([^]]+)";
final String string = "=={{int:filedesc}}==\n"
+ "{{Information\n"
+ "|description = wikiwoordenboek audio\n"
+ "|date =\n"
+ "|source =\n"
+ "|author =\n"
+ "|permission =\n"
+ "|other_versions =\n"
+ "}}\n"
+ "[[Category:Dutch pronunciation|Example]]";
final String subst = "\\1\\5\\3\\4\\5";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}