import re
regex = re.compile(r"(\|description =\s*)([^\n]+)(.*\[\[)([^\|]+\|)([^]]+)", flags=re.DOTALL)
test_str = ("=={{int:filedesc}}==\n"
"{{Information\n"
"|description = wikiwoordenboek audio\n"
"|date =\n"
"|source =\n"
"|author =\n"
"|permission =\n"
"|other_versions =\n"
"}}\n"
"[[Category:Dutch pronunciation|Example]]")
subst = "\\1\\5\\3\\4\\5"
result = regex.sub(subst, test_str)
if result:
print(result)