use strict;
my $str = '=={{int:filedesc}}==
{{Information
|description = wikiwoordenboek audio
|date =
|source =
|author =
|permission =
|other_versions =
}}
[[Category:Dutch pronunciation|Example]]';
my $regex = qr/(\|description =\s*)([^\n]+)(.*\[\[)([^\|]+\|)([^]]+)/sp;
my $subst = '\\1\\5\\3\\4\\5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";