$re = '/(\|description =\s*)([^\n]+)(.*\[\[)([^\|]+\|)([^]]+)/s';
$str = '=={{int:filedesc}}==
{{Information
|description = wikiwoordenboek audio
|date =
|source =
|author =
|permission =
|other_versions =
}}
[[Category:Dutch pronunciation|Example]]';
$subst = "\1\5\3\4\5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;