const regex = /(\|description =\s*)([^\n]+)(.*\[\[)([^\|]+\|)([^]]+)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\|description =\\s*)([^\\n]+)(.*\\[\\[)([^\\|]+\\|)([^]]+)', 'gs')
const str = `=={{int:filedesc}}==
{{Information
|description = wikiwoordenboek audio
|date =
|source =
|author =
|permission =
|other_versions =
}}
[[Category:Dutch pronunciation|Example]]`;
const subst = `\1\5\3\4\5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);