#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b0*1(?=0+~)|\b0+|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*"
Local $sString = "000~09876543210" & @CRLF & _
"0001~09876543210" & @CRLF & _
"1~09876543210" & @CRLF & _
"2~09876543210" & @CRLF & _
"3~09876543210" & @CRLF & _
"004~09876543210" & @CRLF & _
"10~09876543210" & @CRLF & _
"0010~09876543210" & @CRLF & _
"0020~09876543210" & @CRLF & _
"210~09876543210" & @CRLF & _
"438~09876543210" & @CRLF & _
"1000~09876543210"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)