using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b0*1(?=0+~)|\b0+|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*";
string substitution = @"$2";
string input = @"000~09876543210
0001~09876543210
1~09876543210
2~09876543210
3~09876543210
004~09876543210
10~09876543210
0010~09876543210
0020~09876543210
210~09876543210
438~09876543210
1000~09876543210";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}