import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b0*1(?=0+~)|\\b0+|([0-9])(?=0*~[0-9]*?\\1([0-9]))|~[0-9]*";
final String string = "000~09876543210\n"
+ "0001~09876543210\n"
+ "1~09876543210\n"
+ "2~09876543210\n"
+ "3~09876543210\n"
+ "004~09876543210\n"
+ "10~09876543210\n"
+ "0010~09876543210\n"
+ "0020~09876543210\n"
+ "210~09876543210\n"
+ "438~09876543210\n"
+ "1000~09876543210";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}