import Foundation
let pattern = #"\b0*1(?=0+~)|\b0+|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
000~09876543210
0001~09876543210
1~09876543210
2~09876543210
3~09876543210
004~09876543210
10~09876543210
0010~09876543210
0020~09876543210
210~09876543210
438~09876543210
1000~09876543210
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)