use strict;
my $str = '000~09876543210
0001~09876543210
1~09876543210
2~09876543210
3~09876543210
004~09876543210
10~09876543210
0010~09876543210
0020~09876543210
210~09876543210
438~09876543210
1000~09876543210';
my $regex = qr/\b0*1(?=0+~)|\b0+|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";