import re
regex = re.compile(r"\b0*1(?=0+~)|\b0+|([0-9])(?=0*~[0-9]*?\1([0-9]))|~[0-9]*")
test_str = ("000~09876543210\n"
"0001~09876543210\n"
"1~09876543210\n"
"2~09876543210\n"
"3~09876543210\n"
"004~09876543210\n"
"10~09876543210\n"
"0010~09876543210\n"
"0020~09876543210\n"
"210~09876543210\n"
"438~09876543210\n"
"1000~09876543210")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)