#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/"
Local $sString = "phone_nums = c(" & @CRLF & _
" "(123) 456-7890", "(123)456-7890", "1234567890"," & @CRLF & _
" "123 456 7890", "123-456-7890", "123.456.7890")" & @CRLF & _
"not_phone_nums = c("123.456 7890", "123-456.7890", " & @CRLF & _
" "(123 456 7890", "a23.b123.c1234"," & @CRLF & _
" "cleveland rocks"" & @CRLF & _
" )" & @CRLF & _
"stopifnot(all(str_detect(phone_nums, re5)))" & @CRLF & _
"stopifnot(! any(str_detect(not_phone_nums, re5)))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")