# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/"
test_str = ("phone_nums = c(\n"
" \"(123) 456-7890\", \"(123)456-7890\", \"1234567890\",\n"
" \"123 456 7890\", \"123-456-7890\", \"123.456.7890\")\n"
"not_phone_nums = c(\"123.456 7890\", \"123-456.7890\", \n"
" \"(123 456 7890\", \"a23.b123.c1234\",\n"
" \"cleveland rocks\"\n"
" )\n"
"stopifnot(all(str_detect(phone_nums, re5)))\n"
"stopifnot(! any(str_detect(not_phone_nums, re5)))")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.