const regex = ///g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\/', 'g')
const str = `phone_nums = c(
"(123) 456-7890", "(123)456-7890", "1234567890",
"123 456 7890", "123-456-7890", "123.456.7890")
not_phone_nums = c("123.456 7890", "123-456.7890",
"(123 456 7890", "a23.b123.c1234",
"cleveland rocks"
)
stopifnot(all(str_detect(phone_nums, re5)))
stopifnot(! any(str_detect(not_phone_nums, re5)))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}