$re = '///';
$str = 'phone_nums = c(
"(123) 456-7890", "(123)456-7890", "1234567890",
"123 456 7890", "123-456-7890", "123.456.7890")
not_phone_nums = c("123.456 7890", "123-456.7890",
"(123 456 7890", "a23.b123.c1234",
"cleveland rocks"
)
stopifnot(all(str_detect(phone_nums, re5)))
stopifnot(! any(str_detect(not_phone_nums, re5)))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);