// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"/").unwrap();
let string = "phone_nums = c(
\"(123) 456-7890\", \"(123)456-7890\", \"1234567890\",
\"123 456 7890\", \"123-456-7890\", \"123.456.7890\")
not_phone_nums = c(\"123.456 7890\", \"123-456.7890\",
\"(123 456 7890\", \"a23.b123.c1234\",
\"cleveland rocks\"
)
stopifnot(all(str_detect(phone_nums, re5)))
stopifnot(! any(str_detect(not_phone_nums, re5)))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}