import Foundation
let pattern = #"/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
phone_nums = c(
"(123) 456-7890", "(123)456-7890", "1234567890",
"123 456 7890", "123-456-7890", "123.456.7890")
not_phone_nums = c("123.456 7890", "123-456.7890",
"(123 456 7890", "a23.b123.c1234",
"cleveland rocks"
)
stopifnot(all(str_detect(phone_nums, re5)))
stopifnot(! any(str_detect(not_phone_nums, re5)))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)