import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/";
final String string = "phone_nums = c(\n"
+ " \"(123) 456-7890\", \"(123)456-7890\", \"1234567890\",\n"
+ " \"123 456 7890\", \"123-456-7890\", \"123.456.7890\")\n"
+ "not_phone_nums = c(\"123.456 7890\", \"123-456.7890\", \n"
+ " \"(123 456 7890\", \"a23.b123.c1234\",\n"
+ " \"cleveland rocks\"\n"
+ " )\n"
+ "stopifnot(all(str_detect(phone_nums, re5)))\n"
+ "stopifnot(! any(str_detect(not_phone_nums, re5)))";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}