using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/";
string input = @"phone_nums = c(
""(123) 456-7890"", ""(123)456-7890"", ""1234567890"",
""123 456 7890"", ""123-456-7890"", ""123.456.7890"")
not_phone_nums = c(""123.456 7890"", ""123-456.7890"",
""(123 456 7890"", ""a23.b123.c1234"",
""cleveland rocks""
)
stopifnot(all(str_detect(phone_nums, re5)))
stopifnot(! any(str_detect(not_phone_nums, re5)))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}