# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{2}(?=(?:\d{2})+$)/$0\//gm;t' <<< "ACAC | 0 | 01
ACAC | 0 | 0101
ACAC | 0 | 0102
ACAC | 0 | 010201"