import Foundation
let pattern = #"\d{2}(?=(?:\d{2})+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ACAC | 0 | 01
ACAC | 0 | 0101
ACAC | 0 | 0102
ACAC | 0 | 010201
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)