use strict;
my $str = 'ACAC | 0 | 01
ACAC | 0 | 0101
ACAC | 0 | 0102
ACAC | 0 | 010201';
my $regex = qr/\d{2}(?=(?:\d{2})+$)/mp;
my $subst = '$0/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";