import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}(?=(?:\\d{2})+$)";
final String string = "ACAC | 0 | 01\n"
+ "ACAC | 0 | 0101\n"
+ "ACAC | 0 | 0102\n"
+ "ACAC | 0 | 010201";
final String subst = "$0/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}