re = /\d{2}(?=(?:\d{2})+$)/m
str = 'ACAC | 0 | 01
ACAC | 0 | 0101
ACAC | 0 | 0102
ACAC | 0 | 010201'
subst = '$0/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result