# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s\p{Punct}*)(@anybody)(\p{Punct}*\s)/$1text$3/gm;t' <<< "hello, @anybody! How are you?"