import Foundation
let pattern = #"(\s\p{Punct}*)(@anybody)(\p{Punct}*\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"hello, @anybody! How are you?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1text$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)