// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\s\p{Punct}*)(@anybody)(\p{Punct}*\s)").unwrap();
let string = "hello, @anybody! How are you?";
let substitution = "$1text$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}