const regex = new RegExp('(\\s\\p{Punct}*)(@anybody)(\\p{Punct}*\\s)', 'gm')
const str = `hello, @anybody! How are you?`;
const subst = `$1text$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);