re = /(\s\p{Punct}*)(@anybody)(\p{Punct}*\s)/m
str = 'hello, @anybody! How are you?'
subst = '$1text$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result