use strict;
my $str = 'hello, @anybody! How are you?';
my $regex = qr/(\s\p{Punct}*)(@anybody)(\p{Punct}*\s)/mp;
my $subst = '$1text$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";