using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s\p{Punct}*)(@anybody)(\p{Punct}*\s)";
string substitution = @"$1text$3";
string input = @"hello, @anybody! How are you?";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}