$re = '/(\s\p{Punct}*)(@anybody)(\p{Punct}*\s)/m';
$str = 'hello, @anybody! How are you?';
$subst = "$1text$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;